Sabayon 5.2 (soon to be released) on macbook 5.2

For the record I want to explain how to get 5.2 (as soon its out) can be installed successfully on a macbook 5.2 .

I take it one knows about refit, if not RTFM.

The first thing todo when booting the LiveDVD is edit the boot parameters and append: maxcpus=1 . Otherwise the kernel will panic (acpi issue).
Alternatively you can just disable all acpi but this will not do any good for day2day usage of the macbook.

Ok we start installer and we create 1 partition /dev/sda3 I used ext4, works just fine.
In the installer you need to check a box for advanced grub options and
select to NOT install it in MBR but in /dev/sda3 instead.
Personally I think this step actually is a bit buggy because after a
succesfull installation and syncing partition tables in refit you will
get a message that there is no operating system found if you try to
boot the linux partition. This is because it seems that grub2 actually
didn’t install there at all.

To fix this I booted live again to manually install grub here are the
excact steps todo it:

open a terminal, become root

- mkdir sabayon && mount /dev/sda3 sabayon
- mount -o bind /proc sabayon/proc
- chroot sabayon
- grub2-install /dev/sda3 –force (I guess its this step where it went /dev/null during installation process)
- equo update && equo install grub (this will auto generate the shiny
sabayon grub2 theme and detect the kernels)
- exit

Now reboot and there it is. Keep in mind that you still might need to append the maxcpus=1 flag to your line, to perm edit that line you can have a look in /boot/grub/grub.cfg

About these ads
  1. #1 by Michael on July 6, 2010 - 10:24 am

    I tried so hard to get Sabayon onto my mac, in the end i gave up thinking Sabayon didn’t have the efi build of grub, it also stuffed my windows partition too so that was fun, though am still sad i dont have sab’s on here, had to settle for ubuntu it has the grub mac relationship sorted :P

    • #2 by Darryl on August 25, 2010 - 8:00 am

      I have just got Sabayon running on my new Macbook Pro 17″. It works beautifully, but getting it installed was a real trial. I would have liked to try a direct EFI Boot but reluctantly concluded that this would not be a great idea at this stage. I therefore went with REFIT and emulated bios. Then, to overcome the sata disk driver problem I had to use molecule on another machine to make an install DVD with a modified kernel. This at least allowed the live cd to boot and install the system. This step may not now be necessary if the kernel has been updated to 2.6.35 on the live cd. Next problem was caused by the 4 partition limit in Apple’s bios, which apparently does not support extended partitions. Leaving sda1 for the EFI partition and sda2 for OSX, Sabayon by default created a boot partition on sda3 and lvm on sda4. This would not boot with Grub2. Fortunately, I kept a Parted Magic disc handy, and was able to use this to boot. However, the problem with Grub2 is that it needs a very small dedicated partition of its own to work with the GPT partition table. Expermentation revealed that this need not be one of the first four partitions. sda5 or after is okay. Be careful to set the partition type correctly and also the label before updating Grub2. Sync the partition tables with Refit, which will see only sda1 to sda4, and your machine should now be able to boot Sabayon without the Parted Magic disc. My current setup has /boot as sda3, and an lvm partition with / and /swap. / is encrypted. Theoretically, /boot can also be on LVM with Grub2, though the Sabayon installer did not permit this setup. I may try it a little later.

      I also had a little difficulty getting sound working properly (in KDE). Also, wireless networking was okay initially but broke after an update. The wireless card, for some reason, would no longer connect to the access point, and I spent a lot of time trying to isolate the problem. I went so far as to attempt to replace the proprietary wl driver with a windows driver using ndiswrapper, but without success. Finally, I realised that the problem was solved by changing the access point encryption from wpa to wpa2. Evidently the driver supports the latter better than the former. My next effort was with KVM. After modprobing tun, kvm and kvm-intel virt-manager worked well and I was able to use it to install and run a virtual machine. Unfortunately, wireless networking the linux bridging do not seem to work well together. A google search reveals a good workaround involving tap and proxy arp, which I haven’t tried and probably won’t bother at this stage. I do not envisage that any virtual machines run on my Macbook will need to be exposed to the outside network, default nat networking should be fine.

      Overall, I am enjoying the experience. The screen is great. Compositing works well. The battery life does not seem to be too bad. The keyboard layout takes some getting used to, but I’m getting better at it. My next moves will probably be to encrypt the swap partition also, and to move /boot to the LVM.

  2. #3 by Thomas on September 20, 2010 - 7:51 am

    Thanks, this worked for me. It happened to me during my Sabayon 5.3 install, so it’s sad to see the problem not get fixed.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Follow

Get every new post delivered to your Inbox.

Join 174 other followers

%d bloggers like this: