Archive for December, 2010

Update a fresh 5.4 Installation

Since the release of 5.4 many many things changed. As you might have noticed, the Sabayon Linux project is moving fast and many updates are generated every day.

Because we are now a rolling distro and moved some things into the maintenance scope, things that would normally ONLY get updated on a new branch, we had to resolve an issue that some Gnome users ran into. In fact the problem was not a specific Gnome issue but a distro wide problem.

When I bumped glibc because a security reason, Fabio already warned me about problems that could affect our users but we decided to go ahead.

What we learned is that in such a case, glibc on the user end should ALWAYS be installed first. And Fabio wouldn’t be Fabio if he didn’t foresee the need for such a feature and this was already possible to do for some time now. So we moved glibc to the special list and there you have it on a fresh install:

equo update && equo upgrade:

It now wants to first install glibc! You ofcourse should do this (you have no choice using upgrade)

When this is installed you want to install the latest entropy version first:

equo install entropy –relaxed

Finally you can install all the updates.

Remember that Sabayon 5.4 shipped with the 2.6.35 kernel version. If you want the 2.6.36 kernel version (or later whenever it is available in Entropy) you should manually install it. Please refer to our wiki on how to do this.

1 Comment

Follow

Get every new post delivered to your Inbox.

Join 177 other followers